当前位置:首页 > 问答

boll选股公式

我来帮TA回答

布林线上行,调整到中轨的选股公式怎么写(通达信)

BOLL:=MA(CLOSE,20);
UB:=BOLL+2*STD(CLOSE,20);
LB:=BOLL-2*STD(CLOSE,20);
boll>=ref(boll,1) and c>=boll and l<=boll;

求通达信BOLL线突破上轨的选股公式

COUNT(C,"BOLL.UPPER");
适合懒人用,不懂问我,呵呵

请高手帮忙编写通达信 布林线结合量能 的选股公式

朋友,想先和你确认个问题,再帮你编写公式,你布林线使用什么样的变量?

请老师帮忙编写boll选股公式

第一个
短上轨:=EMA(H,10);
短下轨:=EMA(L,10);
长上轨:=EMA(H,20);
长下轨:=EMA(L,20);
XG:C>短上轨=1 AND C>短下轨=1 AND C>长上轨=1 AND C>长下轨=1;
第二个
短上轨:=EMA(H,10);
短下轨:=EMA(L,10);
长上轨:=EMA(H,20);
长下轨:=EMA(L,20);
XG:C>长上轨=1 AND C>长下轨=1 AND REF(C>短上轨,1)=0 AND C>短上轨=1;

如何利用技术指标布林带判断买卖点

布林线指标只会通过自身指标线的变化,告诉投资者未来上升的可 能性更大还是下跌的可能性更大,抑或是未来股价将开启剧烈波动行情或小 幅波动的盘整行情,不过将布林线指标与其他技术指标综合起来分析,不仅可以更加准确地识别买卖点信号,而且还能预测股价大致的上涨或下跌幅度。
1.与K线结合研判买卖信号
例如,当股价K线呈现W底形态时,若第一底部位于布林线指标下轨 线或跌破了布林线指标下轨线,而第二个底部并未到达布林线指标下轨线, 同时第二个底部形成时产生的成交量小于第一个底部,则说明股价未来反弹 向上的可能性很大。
2.与其他技术指标结合研判买卖信号
例如,当KDJ指标出现黄金交叉信号后,指标线进人超买区域,此时 布林线指标通道逐渐变宽,股价沿布林线指标上轨线运行,则说明股价短线呈强势。若KDJ指标出现高位死叉,股价K线也从布林线指标上轨线外侧重返上轨线下方,则属于较明确的卖出信号。
我在知牛财经上面听讲师公开课整理的笔记,希望能够帮助到你咯。合适的话帮采纳一下。

通达信神奇公式怎么选股通达信神奇布林线股票指标公式如下:mid2:=m

{神奇布林线主图}
MID2 := MA(CLOSE,21),COLORWHITE;
UPPER2:=MID2 + 1.96*STD(CLOSE,21),COLORYELLOW;
LOWER2:=MID2 - 1.96*STD(CLOSE,21),COLORYELLOW;
UP2:=MID2 + 2.56*STD(CLOSE,21),COLORFF00FF;
LOOW2:=MID2 - 2.56*STD(CLOSE,21),COLORFF00FF;
{上升趋势}
STICKLINE(C>=MID2,MID2,UP2,2,0),COLOR330066;
{下降趋势}
STICKLINE(C<MID2,MID2,LOOW2,2,0),COLOR545454;
MID:MID2,COLORWHITE;
UPPER:UPPER2,COLORYELLOW;
UP:UP2,COLORFF00FF;
LOWER:LOWER2,COLORYELLOW;
LOOW:LOOW2,COLORFF00FF;
开口:=UP-LOOW;
相离:=C-MID;
DRAWTEXT(C>=MID AND REF(开口,1)=HHV(开口,20),UPPER,'减仓'),COLOR00FF00;
DRAWTEXT(C>=MID AND REF(相离,1)=LLV(相离,5),MID,'加仓');
股价多头:=C>MA(C,5) AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20);
DRAWTEXT(FILTER(股价多头,20),LOOW*0.95,'开始建仓'),COLORRED;
DRAWICON(FILTER(股价多头,20),LOWER,1),COLORRED;
DRAWTEXT(CROSS(MID,C),UP,'空仓观望'),COLORYELLOW;
DRAWICON(CROSS(MID,C),UPPER,2),COLORYELLOW;
{K线}
{STICKLINE((CLOSE > OPEN),CLOSE,OPEN,5.2,0),COLOR070084;}
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,4,1),COLOR0000A3;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3.5,0),COLOR000033;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3,0),COLOR000066;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,2.0,0),COLOR000099;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.0,0),COLOR0000FF;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.3,0),COLORRED;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.3,0),COLORRED;
{STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,5.2,0),COLOR070084;}
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,4,1),COLOR0000A3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,3.5,0),COLOR0000B7;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,3,0),COLOR0000CD;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,2.0,0),COLOR0000E9;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,1.5,0),COLOR0754E9;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,1.0,0),COLOR076EF3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,0.5,0),COLOR077BF3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),OPEN,LOW,0.3,0),COLOR0000CD;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,HIGH,0.3,0),COLOR0000CD;
{STICKLINE((OPEN > CLOSE),CLOSE,OPEN,5.2,0),COLORFF5B00;}
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,4,1),COLORFF6C00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,3.5,0),COLORFF7B00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,2,0),COLORFF9C00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,1.5,0),COLORFFBE00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,0.5,0),COLORFFFF00;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,0.3,0),COLORFF9C00;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,0.3,0),COLORFF9C00;
{STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,5.2,0),COLORFF5B00;}
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,4,1),COLORFF6C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,3.5,0),COLORFF7B00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,2,0),COLORFF9C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,1.5,0),COLORFFBE00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,0.5,0),COLORFFFF00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,LOW,0.3,0),COLORFF9C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),OPEN,HIGH,0.3,0),COLORFF9C00;
====================
{选股}
MID := MA(CLOSE,21);
相离:=C-MID;
加仓:=C>=MID AND REF(相离,1)=LLV(相离,5);
股价多头:=C>MA(C,5) AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20);
开始建仓:=FILTER(股价多头,20);
XG:加仓 OR 开始建仓;